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Introduction 
 
Hyena gives Windows® system administrators and support personnel a single, enterprise-
ready interface for managing nearly every aspect of their networks.  Hyena combines many of 
the functions of the Window built-in administrator tools, while adding its own unique and 
powerful features, including: 
 
• Industry-standard Windows Explorer ® style interface 
 
• Object-oriented approach to management of network objects and functions 
 
• Context-sensitive popup menus 
 
• Easy to understand hierarchical domain browser and viewer 
 
• Summary or detailed views of most system objects 
 
• Tight integration with Windows Explorer for file management, with built-in access to the 

Explorer context menus for file and directory objects 
 
• Access to Microsoft Exchange user mailbox and Terminal Server user configuration 

information. 
 
• Suitable for both LAN and WAN environments, including support for single-object viewing 

over slow WAN links 
 
• Supports Windows NT 4.0, Windows 2000, Windows XP/Vista, Windows 2003 clients and 

servers 
 
• Complete and easy-to-use Active Directory administration, including advanced filtering, 

saved queries, and more. 
 
This Installation and User Guide is intended to help you get familiar with the basics of using 
Hyena, including how use of the keyboard and mouse interacts with the primary windows and 
object displays. 
 
All of Hyena's functions are also summarized in this document.  Additional information is 
available in Hyena's online help file on specific functional areas.  Hyena’s help system is also 
available online at http://www.systemtools.com/HyenaHelp. 
 
SystemTools maintains an email notification list of new features and release information.  To 
join this list, simply complete our signup form at: 
http://www.systemtools.com/hyena/signin.htm. 
 
To access our online discussion board, go to http://www.systemtools.com/HyenaBoard. 
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Installation 
 
Hardware and Software Requirements 
 
Hyena must be installed on a computer running either Windows NT, Windows 2000, Windows 
XP/Vista, or Windows 2003.  Any configuration (workstation, server, domain controller, etc.) is 
supported.  If installed on a server, the server can be operating as a Primary Domain 
Controller (PDC), Backup Domain Controller (BDC), or as a Server.  Windows NT versions 
4.0, 2000, XP, and 2003 are supported.  For the purposes of this documentation, the term 
"workstation" will be used to indicate the target computer that Hyena is being installed on, 
regardless of its use in the network. 
 
Note: Hyena will not operate under Windows 95/98/Me ®. 
 
It is highly recommend that the workstation be a member of one or more domains.  While 
Hyena will operate on a standalone workstation, its use and functionality will be limited.  
 
It is also highly recommended that anyone using Hyena have Domain Administrator privileges, 
as many of the functions that Hyena uses also have this requirement.  If domain administrator 
access has not been granted, some of Hyena's functions may fail due to security violations. 
 
The following table lists the recommended minimum hardware requirements for installation: 
 
Processor - 120Mhz Pentium ® or better 
Memory  - 32mb RAM 
Disk space - 5mb is needed for installation; only 3mb needed for completed installation. 
 
Installing for the First Time 
 
Hyena is distributed on one of the following media types: 
 
• An installation file that uses either a Windows Installer (.MSI) or a non-Windows Installer 

(Setup.exe) installation.  This is the distribution method used for software libraries and 
internet downloads. 

• CD-ROM 
 
To install: 
 
• Turn off virus protection programs. Some virus protection programs are known to 

interfere with the installation program. 
 
• If installing from a downloaded file, first unzip the archive, and execute either the single 

.MSI file or the setup.exe program.  Follow the on-screen instructions for installation, 
which uses a standard wizard-style installation. 
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• If installing from CD-ROM, insert the CD-ROM into the CD drive.  Your computer may be 
configured to automatically run the setup program, which will either be a single .MSI file or 
the setup.exe program.  These files are in the root directory of the CD. 

 
Note: Hyena’s installation will always default to the English install. If installing the 
German or French versions from the CD, these versions, if available, will be in separate 
directories on the CD. 
 
Installation Problems 
 
Note: The following installation problems only apply to Windows NT 4.0 installations.  If 
you are experiencing installation problems on operating systems other than Windows 
NT 4.0, contact technical support at support@systemtools.com 
 
Hyena requires updated and specific versions of certain, yet common,  DLL files. If you 
receive an error trying to run Hyena that references a problem with a DLL file, do the following: 
 
• If you have not rebooted after installation, go ahead and reboot now.  Then try running 
Hyena again. 
 
• See if you have any DLLs named mfc42u.dll or msvcrt.dll in the Hyena installation 

directory, usually in C:\program files\Hyena.  If you find either of these files there, delete 
them. 

 
• Check the versions of mfc42u.dll and msvcrt.dll that are in your SYSTEM32 directory. 
These versions should be the following versions or later: 
 
mfc42u.dll  ->6.00.8665 
msvcrt.dll ->6.00.8337 
 
• If the files in your system32 directory do NOT have these versions, make sure that the 

current files are NOT marked read-only.  If they are marked as read-only, clear the read-
only attribute.  Then, reinstall Hyena again and reboot after installing. 

 
• If after rebooting, you still don't have these versions, then try doing a complete shutdown, 
including turning the power off, then reboot the computer like normal. 
 
• If these files DO have the correct version, then scan your local drives for any duplicates  
of these files, and if you find them, either rename or delete them. 
 
For any new information concerning installation problems, see 
http://www.systemtools.com/hyena/faq.htm.  You can also contact Hyena support at 
support@systemtools.com if you are unable to get Hyena to install correctly.  A Readme.txt 
file is also installed as part of the installation, which contains up-to-date information on 
resolving installation problems. 
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Installing Upgrades 
 
Most upgrades to Hyena usually consist of a several revised files, including Hyena.EXE and 
Hyena.CHM..  Simply run the installation program to install an update or upgrade.  Your 
existing settings will remain intact. 
 
Upgrades to Hyena are available for download from 
http://www.systemtools.com/hyena 
 
Registration 
 
If you have purchased Hyena, your unique product registration serial information will be either 
provided on a printed license certificate, or if you elected electronic delivery, provided in an 
email message.   This information must be entered exactly as provided, including the license 
ID (key), as well as the licensee (company) name.  If the company name is incorrect, contact 
sales@systemtools.com for replacement license information. 
 
Hyena’s license key contains several pieces of information, including the company name, 
number of licenses, options purchased, and maintenance expiration date.  This information 
can be viewed on Hyena’s Tools->Settings->Licensing dialog. 
 
Each time an unregistered copy of Hyena is executed, the Hyena Registration dialog will 
appear.   To register Hyena, and continue to use past the 30-day evaluation, enter your 
unique registration information into the Registration dialog and click the OK button.  To 
continue to use Hyena during the registration period, simply press Enter (leave 
the registration key blank). 
 
Note: After registration, the registration information is written to a file named 
"REGISTER_KEY.DAT".  This file can be typed or read with any text editor, or copied to 
a central network location for shared access.  If used in such a shared installation, 
enough licenses must be purchased to meet the number of users with access to the 
software. 
 
If you upgrade your Standard Edition license to an Enterprise Edition, or add additional 
licenses to your existing license, you will receive a different license.  Enter this new license 
information into Hyena’s Licensing dialog, which is accessed through the Tools->Settings 
menu.  From the Settings dialog, select the Licensing tab, and enter the license information in 
the appropriate location. 
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Overview 
 
Hyena displays all of its information in one of two primary windows, similar to Windows 
Explorer ®.  The leftmost window is referred to in this guide as the tree window, since domain 
objects are arranged in a hierarchical tree-style format, while the rightmost window is referred 
to as the list window, which always displays items in a report/list format. 
 
Using the Tree Window 
 
Objects in the tree window that contain additional subordinate objects will be displayed with a 
small "plus" indicator next to them.  Clicking on the plus indicator will cause the object to 
expand, and all of the subordinate objects will be displayed.  Clicking on the "minus" indicator 
will hide the subordinate objects, effectively hiding the contents of the parent object.  
 

In the example at left, 
the All Users object 
has been expanded to 
show all users in the 
domain named 
"Resource".  The user 
named "Anthony 
Bishert" has also been 
expanded to show all 
of the user properties 
for this user. 
 
The Groups object for 
the user named 
"Anthony Bishert" has 
also been expanded 
to show all of the 
groups that the user is 
a member of. 
 

 
The individual icons used to depict each of the objects in a domain are explained in detail in 
the Feature Summary section of this guide. 
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Using the List Window 
 
Double clicking on an object in the tree window that contains additional subordinate objects 
will result in the information to be displayed in the List window.  In the example below, double 
clicking on the All Users object results in all domain users being displayed in the list window.   
 

Objects 
displayed 

in the list 
window 

can be 
sorted by 

clicking 
on the 

column heading.  In the preceding example, clicking on the Description column heading will 
result in all users to be sorted and displayed by their description.  Clicking a second time on 
the Description column heading will result in the sort to be reversed (descending). 
 
The widths of each of the column headings can be adjusted by moving the mouse between 
any two of the columns and then dragging the borders.  The column heading widths will be 
saved and restored the next time the same type of object is displayed. 
 

Accessing Object Properties and Functions 
 
Objects displayed in any of the windows can be selected by clicking on them once with the 
mouse.  In the list window, multiple objects can be selected at the same time by 

simultaneously clicking on them while holding down 
the shift/control keys.  If the shift key is held down 
while clicking on an object in the list window, a range 
of objects will be selected.  Holding down the control 
key while selecting objects will select additional 
objects. 
 
Once one or more objects have been selected in 
either the tree or list window, clicking with the right 
mouse button will display the appropriate function 
context menu for the object.  In the example below, 
the user ‘ABishert’ has been selected in the list 
window, and the context menu for a User object has 
been displayed. 
 
Note: Some functions will be (disabled) on the 
context menu, depending upon the type of object and 
whether single or multiple objects are selected.  As a 
shortcut, the Properties function for most objects can 
be invoked by double clicking on the object, or the 
Properties button on the toolbar can be used. 



Hyena Installation and User Guide   7 
 

 

 

 

Using the Toolbar 
 
The toolbar contains icons that give quicker access to key functions, as follows: 
 

Object Manager (File->Manage Object View) - The Object Manager to control the 
layout of domains, computers, and groupings of objects in Hyena’s left tree navigation 

window as well as Active Directory and WMI queries. 
 
Export (Tools->Exporter Pro->Export From Selected Objects) – Exporting functions 
are independent, which allows exporting to be run in a separate task, or even as a 

scheduled background task.  The exporting functions are documented both in Hyena's online 
help file and also in a more comprehensive separate StExport.chm file; this file is also shipped 
with Hyena. 

 
Printing - Displays the print dialog, which supports printing all or a selected range of   
objects displayed in the rightmost list window.   

 
Delete  - Deletes the selected object(s).  Also available by pressing the Delete button 
on the keyboard, or selecting the applicable delete option on a popup context menu. 

 
Insert - Displays the appropriate dialog to insert (add) a new object.  Also available by 
pressing the Insert button on the keyboard, or selecting the applicable "create new" 

option on a popup context menu. 
 

Properties - Displays the appropriate dialog for viewing or modifying the properties of 
the object.  Also the same as the "Properties…" option on a popup context menu. 

 
Icon View - Changes the vi ew in the list window to icon view.  This view mode allows 
more objects to be displayed at the same time. 

 
Report View - Changes the view in the list window to report view.  This view allows for 
column headings and information that is more detailed to display. 
 
Stop Query - Aborts / stops the active running query when performing lengthy 
operations.  It may take 10-15 seconds for the query to completely stop. 

 
Refresh - Refreshes the current list window display. 
 
 
Filter – Displays in-place filtering cells in Hyena’s current list window display. 
 
 
Find / Filter - Displays the Find and Filter dialog, allowing searching for items in the 
list window and optionally filtering out records that do not match. 
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Refresh Find / Filter - Refreshes the current list window display with the filter 
enabled. 

 
Copy - Displays the Copy To dialog, which supports copying selected objects in the 
rightmost list window either to a file or to the clipboard. 

 
 

Macro - Display Hyena's dialog for easy generation of macro or batch files from 
information displayed in Hyena's list window. 

 
 

Erase - Erases (clears) the contents of the list window. 
 

 
Hidden Shares - Toggles between displaying hidden shares on servers or 
suppressing the display of hidden shares. 

 
Admin Shares – Toggles between showing administrative (C$,D$, etc.) shares only 
and showing all shares. 

 
Select User Sort - Toggles between sorting users by full name or username in the 
right list window. 
 
Tools - Displays the Tools and Settings dialog.  See the Settings and Options section 
in this guide for more configuration information. 
 
Help - Displays the online help system. 
 

 
  

The Status Bar 
 
The status bar is a small area under the list window used to display messages.  The status bar 
displays messages reflecting the number of objects recently displayed, or the name of the 
most recently clicked on object in the list window. 
  
The Splitter Bar 
 
The splitter bar is the vertical bar that divides the tree and list windows.  Dragging it with the 
mouse can change its position.  Hyena will remember the last position of the splitter bar each 
time it is started. 
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Setup and Configuration 
 
Configuring Multiple Domains 
 
When Hyena is first started, the domain that the workstation is currently logged into will always 
be shown.  If additional Windows NT/200x domains have been setup in your network, they can 
be added into Hyena. 
 

Note: Adding domains in Hyena does not affect or actually create a new 
domain, it simply makes the domain available and known to Hyena's functions. 
 
To add a domain: 
 
• Click on the File menu 
• Select Add Domain… 
• Enter the name of the domain to add and click OK 
• Alternately, the Find All Domains button can be clicked to query the network for all 

domains.  Select the domain(s) to add from the list displayed.  Note that Windows NT 
does not distinguish domains from Windows workgroups. 

 
The newly added domain will be permanently added and will be always available until it is 
removed.   Optionally, Hyena’s Object Manager (File->Manage Object View) can be used to 
add domains as well as position them in the view window, or place them into groupings. 
  
To remove a domain, use Object Manager (File->Manage Object View). Select the domain to 
remove, and click Delete. 
 

Note: Removing domains in Hyena does not affect or actually remove a domain, 
it simply makes the domain unavailable to Hyena and removes it from the tree 
view window. 
 

Settings and Options 
 
A number of user-configurable options and settings are available.  To access the options 
dialog, select Tools from the menu, then select Settings….  See the online help file for more 
information concerning these options, or click the Help button on the Settings dialog.  The 
Settings dialog is divided into several tabbed pages as follows: 
 

General - general preference options, including options to automatically sort configured 
domains on startup, and confirmation options. 
 

User - settings that control behavior for user management functions, including home directory 
options, post user modification batch processing, and many other options. 
 

Home Dir – Hyena supports creation of the user’s home directory and optionally the home 
directory share through custom templates.  Directory and share level security can also be 
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configured in the template.  See Hyena’s online help file for complete information on how to 
configure user home directory templates. 
 

View - settings that affect performance and options to show or hide hidden shares. 
 

Focus - controls which objects (if any) that Hyena can show the contents of when the object 
receives the input focus, through a single mouse click or keyboard action. 
 

GUI - options to allow more advanced features in the various control views (similar to the feel 
of using Internet Explorer 4.0).  To see these features, install Internet Explorer 4.0 or later on 
the system that is using Hyena. 
 

Tools - configuration of user-defined tools and command lines.  This feature is explained in 
more detail in the next section. 
 

Display - configuration options for some of the list window displays.   Allows selecting which 
columns to display, custom column titles, and column display order. 
 

Reporting – options for setting printed output options, as well as the path for Microsoft 
Access (msaccess.exe) and the reporting database, HyenaRpt.MDB.  When the reporting 
options have been enabled, any information displayed in Hyena’s right list window can be 
printed by clicking the Print toolbar button (File->Print), or by selecting Tools->Generate 
Report… from the menu.  Hyena’s reporting features utilize Microsoft Access, thereby giving 
more flexibility and control to printed output. 
 

Licensing – Used to view the current Hyena license key, or to enter the licensing information 
for the Hyena Enterprise Edition. 
 

Exchange 5.5 / Exchange 200x – Configuration of Hyena’s Microsoft Exchange interface 
can be used to add, modify and delete user mailboxes.  Hyena’s Exchange interfaces require 
that the Exchange Administrator program first be installed on the workstation in order to install 
prerequisite DLLs.  Complete information on the configuration of these options are contained 
in the online help file.  To use Microsoft’s native User Manager for Domains Exchange 
interface (Exchange 5.5 only), you do not have to enter any configuration information on this 
dialog.  Hyena’s Exchange 200x interfaces requires that Hyena be installed on a Windows 
2000/XP/Vista/2003 client.  Note: After enabling Exchange integration, restart Hyena. 
 

Remote Control – allows integration with the free SystemTools Remote Control 
Management (STRCM) utility.  More information and downloading of the STRCM can be found 
at http://www.systemtools.com/strcm_frame.htm 
 
WOL -  Enables integration with Wake-On-Lan (WOL) –enabled computers through Hyena, 
including specifying WOL port and broadcast address.  See Hyena’s online documentation for 
more information on WOL and its options. 



Hyena Installation and User Guide   11 
 

 

 

 

Setting up User-Defined Tools 
 
In addition to user preferences and settings, Hyena can be configured to launch any built-in or 
third party tool or utility.   As a more advanced feature, certain "variables" can be put into the 
command string to be executed that is then replaced dynamically with the actual names of the 
objects being manipulated. User-defined tools can be invoked either by selection from the 
Tools menu, or by pressing Ctrl-F1 through Ctrl-F9.  Ctrl-F1 corresponds to the first user-
defined tool, Ctrl-F2 for the second, etc. The tools are also always available as the last option 
on all popup context menus.  A maximum of 50 custom tool commands can be defined. 
 
To access the User-Defined Tools dialog, select Tools from the menu, then Settings….  Click 
on the page labeled Tools to access the custom tools settings. 
 
When configuring a user-defined tool option, the command line to execute can include the 
following special symbols that will be replaced before execution: 
 
%S% - Server Name.  When used in a command line, will be replaced with the name of the 
current server active for the selected object.  Note: Leading "\\" characters will NOT be 
included in the server name command replacement.  If the tool being invoked 
requires the leading backslashes, enter these explicitly into the command 
string.  See the example in the following section. 
 
%E% - Entry.  When used in a command line, will be will replaced with the text of the active 
entry for the selected object.  For a selected item in the rightmost list window, the first column 
is used for the replacement text. 
 
%Cx% - Column reference.  Use "%C1%" to reference the contents of the first column 
(column #1), "%C2%" to reference the second column (column #2), etc. 
 
%Px% - User-entered Parameter.  Use this variable to display a dialog box for entry of a 
parameter of your choice.  Use "%P1%" for the first parameter, "%P2%" for the second, etc. 
 
%WINDIR% or %SYSTEMROOT% - Replace with contents of current environment variable 
definition. 
 
Note: The symbols MUST be entered in uppercase only. 
 
As an example, to invoke the Event Viewer application when any computer or server is 
currently selected (the active entry), enter the command line:  
 
Eventvwr.exe \\%E% 
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To invoke Performance Monitor, enter the command line:  
 
Perfmon.exe -c \\%E% 
 
Additional command line parameters for Performance Monitor allow pre-configured charts and 
settings to be automatically invoked.  See the online help for Performance Monitor for 
complete documentation for command line options 
 
More examples and tips for integrating Hyena with other applications are on the SystemTools 
Software web site at http://www.systemtools.com/HyenaBoard under the Custom Tools topic. 
 
 
Macros 
 
Hyena's macro facility is accessible through the Tools menu (Tools->Create Macro).  The 
macro dialog supports the same special symbols (%E%, %Cx%, etc.) that are used in the 
custom tools feature.  The purpose of the macro function is to generate an output file (typically 
a batch file) from information that is displayed in Hyena's list window.  For example, to 
inactivate a sequence of user accounts that are being displayed and selected, the macro 
command entered would be "NET USER %C1% /active:NO".  Hyena will then substitute each 
selected user and replace the %C1% with the user name and write the output to the 
designated output file.  The output file can then be modified and executed independent of 
using Hyena. 
 
Hyena’s macro option also supports multiple-lines, so that multiple options (commands) can 
be carried out for each selected item in the list window. 
 
Hyena also supports saving and recalling macro settings from a text file. 
 
See Hyena's online help file for more information about using the Macro facility. 
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Feature Summary 
 
Domain Synchronization 
 
In addition to adding/removing domains to the tree window, an entire domain synchronization 
can also be initiated in Hyena.  To perform a complete domain synchronization, right-click on a 
Domain object in the tree window, and select Synchronize Entire Domain from the context 
menu.  To perform synchronization on only a single domain controller, right click on any 
domain controller and select Synchronize Domain Controller.  Hyena will automatically 
detect whether the domain is running Windows NT or Windows Active Directory and, if 
applicable, offer additional synchronization options. 
 
Managing Users - Accessing User Properties 
 
Individual user properties can be accessed by either double clicking on the user, or by right 
clicking on a user and selecting Properties… from the context menu.  Multiple user properties 
can be modified at the same time by simply selecting multiple users in the right list window, 
and then selecting the Properties function. 
 
Accessing User Exchange Information 
 
If the Hyena Enterprise Edition is licensed and configured, the user’s Exchange mailbox 
information can be accessed by right clicking on the user, and selecting the Exchange 
Properties… menu option.  The Exchange Properties option is also available on the General 
user properties dialog. 
 
Adding New Users 
 
To add new users, right click on any user container, such as Domain Users, Users, or any 
Organizational Unit, and select New User… from the context menu.  Adding users follows 
many of the same conventions as used by builtin Microsoft utilities. 

 
Hyena has the option to automatically "set" a password when adding many users at the same 
time. To use this feature, first add a new user, and after entering the passwords, click the Set 
button. Once set, additional new users will automatically inherit the established password, 
without having to enter it each time. 

 
Hyena also uses several customizable techniques to set the security on newly created user 
home directories.  Templates can be configured to automatically create the home directory, 
home directory share, and to set security when a home directory is specified.  Additionally, 
when home directories are created, an optional batch file can be configured to run.  This batch 
file is passed several parameters based on the newly added user and home directory.  It can 
be modified to support many different security conventions.  See the Managing Users topic in 
the online help file for more information on home directory security and using batch 
procedures during user maintenance. 
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Renaming Users 
 
To rename a user, simply select the user to rename in the tree or list window, right click, and 
select Rename User from the context menu.  After typing the new username, Hyena will 
display a dialog for user renaming options. 
 
Other User Functions 

 
Other user functions include copying and deleting, both of which are available as options on 
the user context menu.  Users can also be copied from one computer to another, using the 
Copy User To… function.  However, a new unique SID will be created for the newly created 
user. 

 
The home directory of a user can be explored by expanding the user's property's in left tree 
window, then right clicking on the user's home directory object.   
 
Terminal Server settings for a user can be viewed and modified directly in the user properties 
dialog.  This option is only available in the Hyena Enterprise Edition, and must be configured 
prior to use.  See the instructions in the online help file on how to configure the interface to the 
Terminal Server settings. 
 
Group Management 
 
Hyena supports both Global and Local group management under Windows NT and all 
supported group types under Windows 2000, in addition to viewing group members directly in 
its native tree and list windows.  To access the properties of a group, right click on a group, 
and select the Properties… function from the context menu.  Groups can be renamed simply 
by changing the group name in the properties dialog. 

 
Hyena also supports copying groups and group members, through the Copy Group… and 
Copy Group Members… options, which can be used to quickly create copies of new groups. 
Note that these new groups will have a different SID than the groups that they were copied 
from.  Groups can also be easily renamed by simply changing the name of the group on the 
Group Properties dialog.  Hyena also supports copying of groups to other computers through 
the Copy Group To… option. 
 
Hyena can also display Active Directory group memberships for more than one group by 
selecting the group(s) and selecting View Group Members... option. 
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Object Manager (formerly known as ‘Quick Access’) 
 
One of Hyena's most popular features has always been its 'Quick Access' feature, which lets 
groups of commonly used computers and printers to be added directly into Hyena's navigation 
window.   Hyena improves upon the Quick Access feature by replacing it with a new interface, 
that we call the "Object Manager".  Domains, computers, printers, file folders, even urls, can 
now be grouped in any way that best represents your network organization.  The Object 
Manager can be accessed through the File->Manage Object View option. 
 
Managing Computers 
 
Hyena has extensive support for managing remote computers, including servers, 
workstations, and Windows 95/98 workstations.  By default, only computers that are visible on 
the network are displayed.  To view all computers, even offline or hidden workstations, select 
Tools->Settings from the main menu, then select the View dialog, and enable the View All 
Computers option.  To add new servers or workstations to a domain, right click on the 
Computers object under the appropriate domain and select Add Computer… from the context 
menu. 
 
Right clicking on any server or workstation will display the computer context menu with 
additional options for remote management.  Hyena also includes a number of unique features 
that are available when computers are selected from the right list window, thereby supporting 
these functions on multiple computers at the same time: 
 
• Scheduling – Hyena supports adding, viewing, and deleting remote jobs using both AT 

and the Task Scheduler.  See the Scheduling section below for more information on this 
facility. 

• Service Control – Hyena supports starting and stopping the same service on multiple 
computers, as well as mass service configuration changes.  See the Controlling Services 
and Devices section below for more information on this facility. 

• Events – Hyena can view and filter events on multiple computers at the same time. 
• Changing Password and Adding Member to Local Groups – Hyena supports changing 

the password on a designated account, as well as adding a member to a local group for 
multiple computers at the same time. 

• Viewing Drive Space – Hyena can view the drive space information for multiple 
computers at the same time, thereby giving a quick summary of critical drive space areas. 

• Sessions – Hyena can view and disconnect sessions from multiple computers at the 
same time. 

• Interactive Users – Hyena can be used to display a list of all interactive local logons at a 
workstation, including service accounts. 

 
If a different security context is needed to access the computer, it can be right clicked on in the 
tree display list and the Logon As… option can be used.  Enter the name of a domain or 
server and a valid username/password.  Hyena will then establish a connection to the 
computer using an alternate security context. 
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Viewing Shares, Dfs Shares, and Files 
 
Hyena contains complete support for adding, removing, and changing share properties, 
including share security and Dfs shares (Dfs management is only available in the Enterprise 
Edition).  Individual files and directories can be accessed and managed through any share 
visible from the server, including the administrative shares. 

 
Hyena can also display all share security information for an entire server at the same time.  To 
view this information, right click on the main Shares object, and then select View All Access 
Rights from the context menu. 

 
All file and directory operations in Hyena are integrated into the Windows Explorer interface.  
Right clicking on any file or directory in will display the same popup context menu as Explorer.  
Hyena also has a number of other functions available under the More Functions menu, 
including an “Open By" option for viewing the active users of a selected file in the list window. 
 
Controlling Services and Devices 
 
Double clicking on either the Services or Devices object available for any computer will display 
all service or device driver information.   Viewing only active or inactive services or devices is 
also supported. Hyena also supports modification of all service and device information, as well 
as conventional starting and stopping of services.  Right clicking on any service or driver and 
selecting one of the options from the context menu can access the server control functions. 

 
Modification of the state or startup information of a service on several computers at the same 
time is also supported.  To do this, select one or more computers in the right list window, right 
click, and select either Service Control… or Service Startup… from the context menu.  
Using either of these two functions requires knowing the exact spelling of the service/driver 
name.  Review the Service Control section in the online help file for more information on using 
these functions. 
 
Viewing Disk Space 

 
To view the disk space (both available and used) for any computer, double click the Disk 
Space object available under any server or workstation in the tree window.  Disk space 
information is periodically updated (refreshed) automatically.  To view the disk space for 
multiple computers, simply select the desired computers from the list window, right click, and 
select the View Disk Space option. 
 
Sending Messages 
 
Hyena supports sending messages to either users or computers from a variety of object 
views.  To send a message, simply right-click on any user or computer-related object, and 
select the Send Message… function from the context menu.  To send a message to all of the 
users in a domain, right-click on a Domain object, and select  the Send Message… function. 
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Scheduling Jobs 
 
The job scheduling function uses either the built-in AT or Task Scheduler scheduling system. 
The AT scheduler utilizes the Scheduler service that is installed by default on NT server and 
workstations.  Windows 2000 systems automatically use the newer Task Scheduler.  By 
default, the Scheduler service is not automatically started.  Before scheduling a remote job, 
the Scheduler service must be started, otherwise an error will occur when an attempt is made 
to schedule a job.  The Scheduler service can be started by using the Control Panel Services 
applet, or by using the Hyena service functions.  If a large number of workstations require a 
scheduled job, use the Service Control functions to configure and start the Scheduler service 
for multiple computers at the same time. 
 
One powerful use of the scheduling function is to schedule jobs to run privileged tasks under a 
different username.  Normally, NT/2000 does not allow a user to perform system-sensitive 
operations, such as making configuration changes, or loading service packs.  Instead, an 
administrator must perform these tasks.  Hyena can be used to configure the Scheduler 
service for multiple computers at the same time, and perform many of these administrative 
tasks. 
 
Hyena will automatically display a “Scheduled Jobs” object for all servers and workstations.  
Use the menu for this object to view or add new jobs. 
 
To use the Scheduler functions on multiple computers at the same time, first select one or 
more computers in the right list window, then right-click to display the context menu.   Select  
either Add Remote Job (AT)... or Copy Remote Job (Task)… from the context menu to 
create a new job on multiple computers.  See the online help file for complete descriptions of 
the fields on the job dialogs. 
 
Viewing Events 
 
To view events for any computer, simply double click the Events object available under any 
server or workstation in the tree window.  Alternately, you can also access the events for one 
or more computers at the same time by selecting the computer(s) in the right list window, right 
clicking with the mouse, and selecting View Events from the context menu.  For a complete 
list of event options available, see the Events section in Hyena's online help file.  Hyena 
supports both viewing events using its own builtin event viewer, or using the native Event 
Viewer application. 
 
When using Hyena’s builtin event viewer, events can be filtered in a variety of ways, including 
by event ID, description contents, source, etc. 
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Printers and Print Jobs 
 
Printer properties can be viewed in the list window by double clicking on the Printers object 
available under any computer object.  Individual printers can be paused, restarted, or purged 
(all jobs removed).  To access the printer functions, first select the printer, right click, then 
select an option from the context menu. 
 
Print jobs can be viewed for any printer by first expanding the Printers object and then 
selecting any visible printer.  The print jobs can also be viewed by selecting View Print Jobs 
option from the context menu for any printer.  When viewing print jobs, the display will be 
automatically updated to reflect new or printed jobs.  Print jobs can be controlled (cancelled, 
paused, etc.) by first selecting one or more jobs in the list window, and then selecting the 
appropriate context menu option. 
 
Registry 
 
Hyena can manage the registry of remote computers by expanding and then double clicking 
on any registry hive under any computer object.  Supported functions include creating and 
deleting registry keys and values.  Hyena can also search any key, including entire hives, with 
a variety of options through the registry Search feature, which is available on any registry key 
or primary hive. 
 
Printing and Reporting 

 
Any information displayed in the right list window can be printed or reported.  Printing of only 
selected objects is also supported.  To access the print function, click the Print button on the 
toolbar, or select File->Print.  Hyena’s reporting options reply on the use of Microsoft Access, 
which must be installed and working prior to using the reporting features.  To access the 
reporting options, select Tools->Generate Report… 
 
Exporting / Extracting Information 
 
Hyena includes an interface to the Exporter facility, which includes options for exporting lists 
of users, groups, group members, printers, computers, disk space, shares, and services to 
delimited text files.  The Exporter program is documented in a separate Help file, and is 
included with Hyena.  To access the Exporter program from within Hyena, click the first toolbar 
button, or select File->Export from the main menu. 
 
Hyena also supports copying any information displayed in the right list window to either the 
clipboard or directly to a text file.  To use the Copy functions, first select one or more entries in 
the list window, or press Control-A to select all entries.  Then, select Edit->Copy from the 
main menu, or press Control-C. 
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Domains 
 

 Adding new Windows NT or Windows 2000 domains to view window 
 Removing domains from view window 
 Send message to all domain users 
 Synchronizing all domain controllers 
 Viewing trust relationships 

  
Servers and Computers 
 

  Viewing online and offline (optional) computers 
  View single computer 
 Modify comment/description 
 Add new computer to domain 
 Remove computer from domain 
 View and modify account, audit policies, and user rights 
 View shares and files 
 View and modify registry information 
 View and disconnect sessions and open files 
 View and modify services on one or more computers 
 View events on one or more computers 
 View processes and other performance objects 
 View, add, and manage scheduled jobs and tasks 
 Viewing all used and available disk space on all disk drives 
 Shutdown and (optionally) reboot multiple computers 
 Send messages 
 View interactive (local) user logons 
 Modify single account password on multiple computers 
 Added user/global group to specified local group on multiple computers 
 Modify service startup on multiple computers 
 Start/stop service on multiple computers 
 Remove wakeup 
 Running WMI queries 

 
Shares 
 

 View all shares on any server or workstation (including hidden) 
 View single share 
 View connections 
 Stop sharing 
 Modify properties and permissions 
 View all shares access permissions for entire server 
 Create new share 
 View files and directories 
 Integration with Windows NT 4.0/Windows 2000 Explorer ® 
 Connect network drive (local workstation) 
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Users 
 

 Viewing all users 
 Viewing single user 
 Modifying single and multiple user properties 
 Add/modify/delete Exchange mailbox properties (Enterprise Edition only) 
 Add/modify user terminal server information (Enterprise Edition only) 
 All user properties supported, included dialup (RAS) 
 Reset password 
 Find buttons for login script and profiles 
 Edit login script using Notepad or any user-defined editor 
 Explore option for user home directory (NT 4.0 and later only) 
 Access user home directory share properties, and create user home share 
 Add new user, including copy from existing user (clone) 
 View user logon, including last logon, statistics 
 Rename user 
 Send message to user 
 Delete single or multiple users 

 
Groups 
 

 Viewing all groups (global and local) 
 Viewing single group 
 Adding new group 
 Viewing group members, including group member user detail information 
 Modifying properties and membership 
 Rename group 
 Copy group or group members to new group or existing group 
 Delete groups  

 
Files and Directories 
 

 Viewing of all files and directory contents on any share 
 Properties, including security, auditing, and ownership (NT 4.0 and later only) 
 View all file security information for selected files/directories 
 Copy, moving, deleting files (NT 4.0 and later only) 
 Rename files 
 Print and open 
 Create new files 
 "Open With…" dialog support (NT 4.0 and later only) 
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Printers 
 

 Control printer queue (pause, purge all jobs, resume printing, etc.) 
 Cancel and view print jobs 
 View all printers on any server or workstation 
 View printer setup dialog, properties, document defaults, and spooler settings 
 Connect to printers (local workstation) 
 Remove printer connections (local workstation) 

 
Services and Drivers 
 

 View all services and drivers on any server or workstation 
 Change service state - stop, start, pause 
 View service dependencies 
 Change service state on multiple computers at the same time 
 Delete service (not supported by all services) 
 Change service startup information on one or more computers 
 Install (create) service on more or more computers at the same time 

 
Open Files 
 

 View all open files on any server or workstation 
 Disconnect (close) open files 
 View files open by specific user, or view users having a specific file open 

 
Sessions 
 

 View all user sessions on any workstation or server, including multiple computers 
 Disconnect sessions 
 Send messages to users 

 
Events 
 

View events from one or more workstations/servers using built-in viewer, including 
filtering and searching for specific event(s) 
 
View events (through Event Viewer) on any workstation or server 
 
 

Disk Space 
 

 View disk space information for all drives on one or more remote computers 
 Automatic disk space refresh interval 
 Direct access to Explorer functions for all disk drives
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Performance Monitoring  
 

View processes and other performance items on any remote computer running 
Windows NT/2000/XP 
 

Scheduled Jobs / Tasks 
 

AT compatibility 
Task Scheduler compatibility 
Add, modify, or delete any job/task 
Add new AT tasks to multiple computers  
Copy (clone) task from one computer to multiple computers 
Start or terminate remote task (Task Scheduler only) 
View scheduled jobs/task on multiple computers 
 

Registry 
 

 View registry hive and key contents 
 Create new registry key and values 
 Modify registry values 
 Delete registry key and values 
 Search registry keys and hives 

 
WMI 
 
Create WMI Queries 
Execute WMI Queries 
Modify WMI instance properties 
Execute WMI methods on selected instances 

 
Exporting / Copying Information 
 
Export users, groups, group members, computers, services, disk space, and printer 
definitions to tab-delimited text files for all server or workstations in any domain.   

 
 Copy information displayed in list window to clipboard or text file 
 
Miscellaneous 
 
 Print or report the contents of any portion of the list window 
 Configure user-defined tools and command line options 

Generate text output file using macro facility from anything displayed in list window. 
 


