Results 1 to 4 of 4

Thread: Terminal Server data error

  1. #1

    Terminal Server data error

    When accessing the User Properties Terminal TAB or creating a new User I receive following error:
    "Error getting Terminal Server data. Parameter is incorret".
    My environment is Win7, Hyena 11.2.5 (F), latest MS patch level.
    5 Terminal Servers in farm using Gateway/Broker, individual TS data and sessions data are all available from within Hyena.

    This error appeared after upgrading from Hyena 11.2.2
    Another install using version 11.2.2 works as expected.

    Please advice .

  2. #2
    Try this, go to Tools > Settings > Advanced, and scroll down towards the bottom of the list, find the setting named "UseNetbiosOnTseFunctions" and set this to 'True'. Then try viewing the properties of an account.
    Kevin Stanush
    SystemTools Software Inc.

  3. #3

    Solved

    Quote Originally Posted by missioncritical View Post
    Try this, go to Tools > Settings > Advanced, and scroll down towards the bottom of the list, find the setting named "UseNetbiosOnTseFunctions" and set this to 'True'. Then try viewing the properties of an account.
    Issue is solved - perfect .
    For your information my other instance of Hyena running v11.2.2 does have this registry setting at False and does not have this issue.
    - difference being the specifying of an ADSI Server.

    Thx for your speedy reply.

  4. #4
    There are two ways that this problem can crop up on newer versions, so we are enabling this option by default for the next release of Hyena.

    If you have an ADSI Server specified, and provide a DNS name, then Hyena uses this server for all AD operations. Some functions, such as RAS and Terminal Services, don't use Active Directory, so a computer name must be used instead. For reasons that defy mortal explanation, Microsoft functions that update terminal services settings will not accept a DNS-formatted host name. Before this new setting in Hyena, we had to tell customers to use a Netbios path instead either for their ADSI Server or path to the domain, which is not an optimal solution.

    Hyena v11.2 also will by default include the user's domain automatically as a DNS-formatted domain path, so this new behavior will also create errors when trying to update TSE settings, so again having this option as the default will hopefully make some problems go away.

    Thanks for reporting this issue as it reminded us of this constant and pesky error that just seemingly will not be fixed by Microsoft, and to change our defaults going forward.
    Kevin Stanush
    SystemTools Software Inc.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •