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SystemTools Software Inc. 

Hyena Installation Guide 

 

 

SystemTools Software, Inc. has created this document to cover all requirements to 

install and fully use all of the features of SystemTools Hyena. 

Additional information on Hyena and other SystemTools Software products can be 

found on our website: 

http://www.systemtools.com/ 

Additional support information can be found on our Support Options page: 

http://www.systemtools.com/support.htm 

 

http://www.systemtools.com/
http://www.systemtools.com/support.htm
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Hardware and Software Requirements 

 

Hyena must be installed on a Windows-based computer running Windows XP, Vista, 

Windows 7, Windows 8/8.1 or Windows 10 client operating system, or Windows 

2000, 2003, 2008, 2012 or 2016 server.  The computer can be configured as a 

workstation, server, or domain controller.  

It is highly recommended that anyone using Hyena have Domain Administrator 

privileges, as many of the functions that Hyena uses require full administrative 

rights. Without administrator access, some of Hyena's functions may fail due to 

security restrictions. 

Managing Active Directory 

Managing Active Directory requires installation of the Microsoft Active Directory 

Administration Tools: 

 Windows 10: Install the Remote Server Administration Tools (RSAT) found on 

Microsoft’s website: 

https://www.microsoft.com/en-us/download/details.aspx?id=45520 

 Windows 8.1: Install the Remote Server Administration Tools (RSAT) found on 

Microsoft’s website: 

https://www.microsoft.com/en-us/download/details.aspx?id=39296 

 Windows 8: Install the Remote Server Administration Tools (RSAT) found on 

Microsoft’s website: 

http://www.microsoft.com/en-us/download/details.aspx?id=28972 

 Windows 7, Vista, 2008: Install the Remote Server Administration Tools (RSAT) 

found on Microsoft’s website: 

http://www.microsoft.com/download/en/details.aspx?id=7887 

 Windows XP and Windows 2003: Install the Windows Server 2003 

Administration Tools Pack (adminpak.msi) found on Microsoft’s website: 

http://www.microsoft.com/download/en/details.aspx?id=16770 

 

https://www.microsoft.com/en-us/download/details.aspx?id=45520
https://www.microsoft.com/en-us/download/details.aspx?id=39296
http://www.microsoft.com/en-us/download/details.aspx?id=28972
http://www.microsoft.com/download/en/details.aspx?id=7887
http://www.microsoft.com/download/en/details.aspx?id=16770
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Hyena will report an error if the Administration Tools are not installed. When RSAT has 

been installed onto a Windows computer and Hyena still reports an error about missing 

AdminPak, the following setting should be enabled: 

 

Open Control Panel  >  Programs  >  

Turn Windows features on and off, 

navigate to "Remote Server 

Administration Tools" and enable the 

"AD DS Snap-ins and Command-line 

Tools" option: 

Click OK and Windows will install the 

Tools necessary for Active Directory 

management. 

 

Two additional settings in Hyena may need to be verified. 

 

Tools > Settings > Active 

Directory: Enable Active 

Directory Support. 

This setting should be 

enabled by default. 
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File > Manage Object 

View > Objects and set 

Type to Windows Active 

Directory Domain. The 

ADSI Path should be in 

Fully Qualified Domain 

Name (FQDN) format, 

such as: 

LDAP://systemtools.local 

 

 

 

 

Managing additional domains or adding objects to Hyena’s view. 

The Objects tab in Object Manager is used for adding objects to Hyena’s left window, 

such as additional domains, Container/OU shortcuts, Object Groupings, etc. The full 

list of supported object types can be seen by clicking the Type drop-down. 

To create a new entry, first click the New button, select an object type, complete the 

appropriate fields for the type of object being added, then click on the Add button. 
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Microsoft Exchange Server 2000/2003 

Note: Exchange Server management is a feature of the Enterprise Edition of Hyena. 

When using Hyena to manage Microsoft Exchange 2000/2003, installation of the 

Microsoft Exchange System Management Tools is required. The functions needed by 

Hyena are included in the Exchange System Management Tools which can be found 

on the Exchange Server 2003 CD-ROM. 

Microsoft’s installation information and requirements page can be found here: 

http://technet.microsoft.com/en-us/library/bb123850(v=exchg.65).aspx 

Once the Exchange System Management Tools are installed, the next step will be to 

configure Exchange settings in Hyena.  

 

To do this, select Tools > 

Settings > Exchange 

2000/2003 in Hyena and 

configure the settings similar 

to the following. 

Hyena will need to be 

restarted after making this 

change. 

Hyena’s help file has 

additional information on 

configuring Exchange mailbox 

templates, etc.

http://technet.microsoft.com/en-us/library/bb123850(v=exchg.65).aspx
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Microsoft Exchange Server 2007 

Note: Exchange Server management is a feature of the Enterprise Edition of Hyena. 

Hyena supports the management of Exchange Server 2007 user properties, but not 

mailbox creation or removal.  Exchange Server 2007 lacks the capability for Remote 

PowerShell (see Microsoft Exchange Server 2010/2013 below), thereby preventing 

mailbox creation and removal.  

To enable the option to update Exchange Server 2007 mailbox properties, select 

Tools > Settings > Exchange 2007/2010/2013 and enable the 'Enable Exchange 

2007/2010/2013 Integration' option.  The ‘Mailbox Properties’ option will then be 

available as a submenu on any Active Directory user context menu. 

Installation of the Exchange 2007 Management Console or any Microsoft Exchange 

administration software is NOT required. 

Microsoft Exchange Server 2010/2013/2016 

Note: Exchange Server management is a feature of the Enterprise Edition of Hyena. 

Note: Although not required by Hyena, it may be useful to install the Exchange Server 

201x Management Tools. This will ensure that the appropriate components needed by 

Hyena will be in place. For more information on the Exchange Server 201x 

Management Tools, visit: 

http://technet.microsoft.com/en-us/library/bb232090.aspx 

Microsoft Exchange 201x uses Windows PowerShell for adding and disabling 

Exchange 201x mailboxes. PowerShell 2.0 or later contains a feature named 'Remote 

PowerShell' (RPS) which allows a client to remotely execute PowerShell commands 

on another computer.  Hyena uses an intermediary component named the 

'SystemTools PowerShell Interface', which is contained in the file named 

SystemTools_PSI.dll. This component is essentially an engine that communicates to 

Microsoft Exchange 201x using the remote capabilities of PowerShell.  

PowerShell 2.0 or later must be installed for Hyena to manage (ie add or disable) 

Exchange 201x mailboxes. PowerShell is also needed to access any of the 'Find' 

buttons in Hyena for Exchange 201x settings or templates. PowerShell is NOT 

needed to modify or view any mailbox properties, since these interfaces access and 

modify Active Directory attributes. 

http://technet.microsoft.com/en-us/library/bb232090.aspx
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To determine the PowerShell version, the following steps can be performed: 

Click the Windows Start button and choose All Programs > Accessories > 

Windows PowerShell > Windows PowerShell. At the PowerShell prompt type in 

the ‘$host’ command.  The ‘Version’ should be 2.0 or later as seen below: 

 

 

Type exit to close the PowerShell window. 

If PowerShell needs to be updated, more information can be found on Microsoft’s 

site: 

http://technet.microsoft.com/en-us/library/hh847837.aspx 

The SystemTools PowerShell Interface (SystemTools_PSI.dll) requires the 

installation of the Microsoft .NET Framework. The installation of PowerShell with 

RPS will ensure that all required components are installed, including Microsoft .NET. 

There are three (3) basic steps to enable the Exchange 2010/2013 management 

options in Hyena: 

1. Enable Exchange 2010/2013/2016 Integration 

Select Tools > Settings > Exchange 2007 and Later and enable the 'Enable 

Exchange Integration (2007 and later versions)’ option. 

http://technet.microsoft.com/en-us/library/hh847837.aspx
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2. Set the Exchange Server 

NOTE: In cases where Hyena is being executed directly on the Exchange server, for 

example, through a remote RDP session or other remote product, then this step can be 

skipped. In cases where Hyena does not know which server to use for a remote 

Exchange function, the local computer will be used. If Hyena is being executed on a 

typical client computer or any computer that is not acting as an actual Exchange 

server, then this step must be performed. 

Hyena uses the remote capabilities in Windows PowerShell for Exchange 

administration. One advantage to this is that it is not necessary to install the 

Exchange administration tools on the local computer. One disadvantage is that the 

local computer does not know anything about Exchange. Remote PowerShell (RPS) 

requires that all functions be executed on a remote computer, and since Exchange 

functions must be carried out by an Exchange server, the remote computer in this 

case must be an Exchange server.  

To provide flexibility and eliminate any assumptions, Hyena provides a way to 

assign an Exchange server to a given domain. The domain in this case is any domain 

whose users have associated Exchange mailboxes. Use the 'Add', 'Edit', and 'Remove' 

buttons under the 'Exchange Server Domain Assignments' list to manage these 

assignments. 

The 'Assign Exchange 2010 Server' feature can be used to find Exchange servers, but 

will also require a server to execute the corresponding PowerShell 'Get-

ExchangeServer' command on.  

 

3. Configure Templates (optional) 

To make it easier to create mailboxes on multiple Exchange databases, one or more 

templates can be optionally created. The purpose of the template is to simply store 

the mailbox database name.  

After enabling Exchange integration and clicking OK, Hyena will register the 

SystemTools_PSI.dll.  
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The Exchange 2010/2013 settings will look similar to the following: 

 

 

Click the Add button beside Exchange Server Domain Assignments and enter a DNS 

formatted Domain Name, as well as the name of an Exchange Server: 
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Click the Find button and if everything is properly configured the following dialog 

should appear: 

 

 

 

Note: The error message "Class not registered" being displayed after using the 'Find' 

button to find an Exchange Server, or when creating an Exchange mailbox, is an 

indication that the SystemTools_PSI.dll could not be registered. 

 

Hyena will automatically attempt to register the SystemTools_PSI.dll file when 

enabling the Exchange 2007/2010/2013 Integration. The registration process 

required by Windows for the SystemTools_psi.dll file uses a Microsoft utility named 

'regasm.exe', which can be found on any system with the Microsoft .NET Framework 

installed.  

Windows 8 and Server 2012 systems ship with Microsoft .NET Framework 4.5. 

Microsoft .NET Framework 3.5 will also need to be installed for Microsoft Exchange 

functionality in Hyena.  
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If Hyena is installed on a Windows 8 or Server 2012 system, the following needs to 

be added under Control Panel > Programs > Turn Windows features on or off: 

 

.NET Framework 3.5 (includes .NET 2.0 and 3.0) 

 

 

Start Hyena and enable Exchange 2007/2010/2013 again and Hyena should be able 

to register the SystemTools_PSI.dll. Test proper connectivity by clicking the Find 

button again on the Exchange Server Domain Assignment: 
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If this still fails with a Class Not Registered error, it is possible to manually register 

the .dll. From a Command Prompt search the C: drive to find the location of 

regasm.exe. Navigate to that directory and enter the following command: 

Regasm.exe “c:\program files\hyena\systemtools_psi.dll” 

That should load the SystemTools_psi.dll and allow for configuration and use of the 

Exchange Server 2010/2013/2016 functionality in Hyena. 

Note: Another common error when enabling Exchange 2007/2010/2013/2016 

functionality is: 

 

 

Running Remote PowerShell (RPS) commands on the Exchange Server requires the 

account running Hyena be a member of the Organization Management group in 

Active Directory. Adding this account to the Organization Management should 

correct the above error, as well as allow for remotely managing Exchange. 
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With Exchange 2010/2013/2016 Integration, right-click on an existing user and 

choose Exchange 2007/2010 Functions > Mailbox Properties to see the 

following Dialogs. 
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Terminal Server User Properties 

NOTE: Terminal Server management is a feature of the Enterprise Edition of Hyena. 

Hyena allows viewing and managing Terminal Server user properties such as 

profile, home directory, and session settings. 

 

 

To enable Terminal Server 

functions in Hyena select 

Tools > Settings > User and 

enable the option to ‘Show 

user thin client (Terminal 

Server) information’.  

Restart Hyena after making 

this change. 
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To view Terminal Server information, right-click on a user and select the 

Properties option.   The User Properties dialog will have a ‘Terminal’ tab as shown 

below: 

 

 

Click the Config button to view the Terminal Client Configuration dialog: 
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In some cases the following error message may be displayed when selecting User 

Properties > Terminal: 

 

 

 

This error is displayed in some environments and is caused by the Microsoft 

Terminal Server functions not supporting DNS formatted paths, such as: 

systemtools.local. 

An Advanced Setting was added to Hyena v10.5 ‘D’ to use a Netbios formatted 

server name for Terminal Server functions. If experiencing this issue go to Tools > 

Settings > Advanced and change the UseNetbiosOnTseFunctions setting to True: 
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If using a version of Hyena prior to v10.5 ‘D’, the workaround is to add an ADSI 

Server for the domain object in NetBios format, by selecting File > Manage Object 

View > Objects, then select the domain and enter an ADSI Server entry as shown 

below: 

 

 

 

The ADSI Server entry will need to be in the format of NetBios format such as 

supportDC, rather than supportDC.systemtools.local. After entering the ADSI Server, 

click ‘Update’ to save the change and then click OK to close Object Manager. 

 


